MULTICOPTER.RU
http://multicopter.ru/forum/

Вопросы новичка.
http://multicopter.ru/forum/viewtopic.php?f=12&t=435
Страница 19 из 27

Автор:  The_0ne [ 04 фев 2011, 23:10 ]
Заголовок сообщения:  Re: Вопросы новичка.

Сори за глупый вопрос, но не могу найти площадку I2C на плате FlightCtrl версии 1.3(((
Подскажете?

PS
Вот блин) Слона то я и не приметил) Искал маленькие, а они она какие здоровенные))) "D" и "C" называются, да ведь?

Автор:  Andrey-multicopter [ 05 фев 2011, 00:02 ]
Заголовок сообщения:  Re: Вопросы новичка.

The_0ne писал(а):
Сори за глупый вопрос, но не могу найти площадку I2C на плате FlightCtrl версии 1.3(((
Подскажете?

PS
Вот блин) Слона то я и не приметил) Искал маленькие, а они она какие здоровенные))) "D" и "C" называются, да ведь?



Да, правильно! :D

Автор:  The_0ne [ 05 мар 2011, 23:56 ]
Заголовок сообщения:  Re: Вопросы новичка.

Коллеги, помогайте!
Итак, есть собраный коптер с работающим полетным контроллером - с него идет телеметрия, МКтул адекватно показывает все графики.
А вот с контроллерами беда(
Конфигурация - квадро. Адреса контроллеров задал перемычками, на 38 раз проверил все соединения на обрывы/кз/переполюсовку, подключил моторы, аккумулятор и тут меня поджидал первый сюрприз. Взрывается конденсатор С16 на третьем контроллере...
Дальше начинается мистика. Посчитав что этот кондер на питании возможно был с браком впаян, я отколупал его остатки с платы и вновь подключил питание. Два контроллера благополучно стартанули, дернули моторами,а вот потом начались чудеса. Полетный контроллер зловещще зажег оба светодиода и начал истошно вопить о чем-то, а мктул сказал что потерян первый контроллер... Самое забавное заключается на данный момент в том, что тот самый третий контроллер, который покалечился при первом включении, исправно работает и весело крутит пропеллером. Еще два контроллера слааааабенько так светят зеленым светодиодиком, а еще один то красным с зеленым, то просто зеленым с периодичностью в пару секунд.
Что это может быть? мож кто сталкивался?

Автор:  vis [ 06 мар 2011, 00:03 ]
Заголовок сообщения:  Re: Вопросы новичка.

проверяйте наличие +5в на атмегах контроллеров...
слабо светит диод - нет питания... ( у меня так на тестовом квадрике, если не подано питание от батарейки на контроллер, но при этом основная плата питается и на i2c есть мастер)

Автор:  The_0ne [ 06 мар 2011, 00:13 ]
Заголовок сообщения:  Re: Вопросы новичка.

А куда могло подеваться питание на мегах? Ведь усе припаяно вроде как требуется.
И, я правильно понял, что если питание на меге отсутствует, то светики вполне могут светиться от I2C

Автор:  vis [ 06 мар 2011, 00:17 ]
Заголовок сообщения:  Re: Вопросы новичка.

для начала нужно проверить :)
слабо тестером потыкать чтоль?
а уж куда оно у вас делось - смотреть дальше...

Автор:  The_0ne [ 06 мар 2011, 00:22 ]
Заголовок сообщения:  Re: Вопросы новичка.

Ну, тестером то я потыкал в первую очередь) Что уж вы так плохо обо мне думаете))))
правда тыкал я в контактные площадки питания контроллеров. Надо будет завтра еще в лапки меги потыкать.

Автор:  The_0ne [ 06 мар 2011, 00:59 ]
Заголовок сообщения:  Re: Вопросы новичка.

Вот блин мистика. Ладно, надеюсь я ничего не спалил и завтра разберусь) Всем спокойной ночи!

Автор:  The_0ne [ 06 мар 2011, 13:41 ]
Заголовок сообщения:  Re: Вопросы новичка.

Поздравляйте с первым блином)
Сегодня утром все заработало - моторчики крутятся, все светиться зеленым. Но это только после первого включения.
Потом сгорают шунты у двух контроллеров, а потом и полетный контроллер.
Все, руки опустились, так как причину такого поведения я так и не обнаружил.
Двигатели - DT700, кз в обмотках и проводах нет, обрывов тоже. Понятно что где-то сам накосячил, но вот где?
А на полетном контроллере тускло и грустно горит зеленая лампочка, а проц греется как утюг.
Сижу и думаю, каким макаром я мог ТАК лажануться?
Ведь все соединения были проверены на 28 раз

Автор:  Andrey-multicopter [ 06 мар 2011, 14:23 ]
Заголовок сообщения:  Re: Вопросы новичка.

Это только переполюсовка - такие последствия только от этого могут быть. Бывает взгляд "замыливается" и кажется, что все нормально, а на самом деле плюс с минусом перепутан. Может быть конденсаторы неправильно припаяли. Но проблема именно в этом - однозначно.

Страница 19 из 27 Часовой пояс: UTC + 3 часа
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/