MULTICOPTER.RU
http://multicopter.ru/forum/

Проблема
http://multicopter.ru/forum/viewtopic.php?f=3&t=217
Страница 2 из 8

Автор:  Matrixro [ 20 май 2010, 19:54 ]
Заголовок сообщения:  Re: Проблема

Да, норм все. Кривизне взяться пока неоткуда, собрано все аккуратно, стойки пластиковые нормальные, не кривые, одинаковые. Ударов, крешей не было :) Сброс делал. Есть смысл прошивку перезалить, может как нибудь не так легла?

Автор:  Matrixro [ 23 май 2010, 13:00 ]
Заголовок сообщения:  Re: Проблема

Поэкспериментировав, пришел к выводу, что не исправный мотор, регулятор, винт и что то криво собранное не может влиять на стабилизацию. Вывод сделан из следующих действий - менял настройки газа в окне "Настройки микширования" Ни увеличение, ни уменьшение на одном из моторов оборотов не приводит к дисбалансу, даже с отключенным одним мотором коптер пытается висеть на месте. Значит механика здесь не причем. Могу предположить, что если поставить основную плату под углом в 30 градусов и все откалибровать, то коптер будет стабильно висеть.
Поэтому проблема остается открытой, не могу корректно откалибровать акселерометры, при выставлении по уровню, коптер несет по диагонали вперед-влево. При этом в окне 3D коптер ориентирован правильно и точно отображает положение реальной модели. Побывал пере прошить и настроить все заново, безрезультатно. Я в замешательстве, с механикой все ок, с электроникой вроде как тож все нормально, все работает, а ошибка есть, приходится делать калибровку предварительно наклонив коптер назад-вправо.

Автор:  Andrey-multicopter [ 23 май 2010, 15:33 ]
Заголовок сообщения:  Re: Проблема

Вы проверяли графики гироскопов и акселлерометра в главном окне программы MKTool? На сколько отличаются цифры между показаниями гироскопов и акселлерометра? При наклоне платформы вместе ли следуют графики гироскопов и акселлеромтров (соответствующие - желтый с красным, зеленый - с синим)?
При остановке платформы графики идут ровно в одну линию?
В зеленом окне MKTool в третьем меню (там где каналы) при отпущенных ручках возле всех управляющих каналов (кроме газа) стоят нули?
Все это нужно проверять.

Автор:  Matrixro [ 24 май 2010, 10:55 ]
Заголовок сообщения:  Re: Проблема

Графики:
Покой:
Вложение:
Покой.jpg
Покой.jpg [ 46.54 KiB | Просмотров: 2295 ]

Крен лево-право, тангаж вперед-назад:
Вложение:
Повороты.jpg
Повороты.jpg [ 43.53 KiB | Просмотров: 2295 ]


Центральное положение ручек... вот оно то... в общем оказалось на тангаже и крене по цифре 9, не знал что в том окне смотреть можно, смотрел только в настройках во вкладке каналы.
Андрей, большое спасибо! Прошу прощение за не внимательность :oops:

Автор:  Andrey-multicopter [ 24 май 2010, 16:00 ]
Заголовок сообщения:  Re: Проблема

Второй график у Вас нормальный - гироскопы и акселлерометры в одной фазе. Если немного изменить настройки в окне "Gyro", то графики будут вообще вместе.
А первый график непонятно, что за дергания белого цвета - это график гироскопа Gyro? Или что-то другое?

Автор:  Letalkin [ 24 май 2010, 20:20 ]
Заголовок сообщения:  Re: Проблема

ай, возмите лупу :-)
на первом графике всё нормально, та-же значения от 0 до -3, это нормально. :-)
.

Автор:  qazontin [ 20 окт 2010, 11:42 ]
Заголовок сообщения:  Re: Проблема

Собрал базовую 6-ку, загрузил в Kopter_Tool_V1_70a конфигурацию Hexa, на этапе проверки работы двигателей возник вопрос:
при проверке моторов с номером 1 крутятся моторы 1-4 одновременно, и при проверки 5-го крутятся 5-6 соот-но.
В чем корень проблемы: где то ошибка в сборке или надо настраивать програмно??

Автор:  Letalkin [ 20 окт 2010, 16:53 ]
Заголовок сообщения:  Re: Проблема

неправильные адреса контроллеров
Какие контроллеры? 1.3 или 2.0 ?

.
погодь
1-4 в вашей интерпретации ето все вместе, т.е. 1 2 3 4й ?, 4-е сразу?
читайте инструкцию по адресации контроллеров
.

Автор:  qazontin [ 20 окт 2010, 17:01 ]
Заголовок сообщения:  Re: Проблема

есть такое дело, не проставил перемычки на адресах контроллеров... стыдно)

есть другой, не менее нубский вопрос:
следуя инструкции со странички
http://russokopter.ru/faststart#parameters
добрался до пункта запуск двигателей:
ручка шаг-газ вниз-право, а в ответ дискретное пикание биппера и отсутствие реакции моторов.
Что я упускаю?

Автор:  osnwt [ 20 окт 2010, 17:04 ]
Заголовок сообщения:  Re: Проблема

qazontin писал(а):
Что я упускаю?

Откалибровать гироскопы?

Страница 2 из 8 Часовой пояс: UTC + 3 часа
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/